const regex = /^(?!(?:01234|12345|23456|34567|45678|56789|67890|78901|89012|90123)$).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!(?:01234|12345|23456|34567|45678|56789|67890|78901|89012|90123)$).*$', 'gm')
const str = `12345
32345
55555`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}