re = /^(?!(?:01234|12345|23456|34567|45678|56789|67890|78901|89012|90123)$).*$/m
str = '12345
32345
55555'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end