$re = '/^(?!(?:01234|12345|23456|34567|45678|56789|67890|78901|89012|90123)$).*$/m';
$str = '12345
32345
55555';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);