#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^(?:\d+_){4})(card\d+)_(port\d+)"
Local $sString = "192_168_10_2_card02_port01_other_text_with_card_or_port" & @CRLF & _
"10_22_1_200_card4_port5_another_string_with_port_or_card" & @CRLF & _
"something_else_with_card_or_port_in_it" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"And in a second call, I'd like to match a different word in these strings." & @CRLF & _
"192_168_10_2_card02_port01_other_text_with_card_or_port" & @CRLF & _
"10_22_1_200_card4_port5_another_string_with_port_or_card" & @CRLF & _
"something_else_with_card_or_port_in_it"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")