re = /(^(?:\d+_){4})(card\d+)_(port\d+)/m
str = '192_168_10_2_card02_port01_other_text_with_card_or_port
10_22_1_200_card4_port5_another_string_with_port_or_card
something_else_with_card_or_port_in_it
And in a second call, I\'d like to match a different word in these strings.
192_168_10_2_card02_port01_other_text_with_card_or_port
10_22_1_200_card4_port5_another_string_with_port_or_card
something_else_with_card_or_port_in_it'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end