#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[0-9]{1,3}[\s]*?[_|.,:;][\s]*?[0-9]{1,3}[\s]*?[_|.,:;][\s]*?[0-9]{1,3}[\s]*?[_|.,:;][\s]*?[0-9]{1,3}[\s]*?:[\s]*?[0-9]{3,6}"
Local $sString = "127 , 0 _ 0; 1 : 45345" & @CRLF & _
"zapraszamy na {1.2.3.1:4564}" & @CRLF & _
"ksk.sls.ss.ll:asas" & @CRLF & _
"121.121.12.11:4545" & @CRLF & _
"127 . 0 . 0 . 1 : 1234 asdasdsadafasdgdsfs sdfgsdfg" & @CRLF & _
"127 . 0 . 0. 1 : 45345 ksasdklasda ka sdk laksj dlkasj dlka sdlaksjd laksjd lkakjsdl ajksdl a" & @CRLF & _
"121.121.12.11:4545" & @CRLF & _
"127.0.0.1:1234" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")