#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?<!> )((\d{1,}\.|-|\/\/|\%\%|\#) )(\[[x ]\] )?)"
Local $sString = "- 测试" & @CRLF & _
"- [ ] 测试" & @CRLF & _
"- [x] 测试" & @CRLF & _
"1. 测试" & @CRLF & _
"2. [ ] 测试" & @CRLF & _
"2. [x] 测试" & @CRLF & _
"" & @CRLF & _
"- (✅)测试" & @CRLF & _
"- [ ] (✅)测试" & @CRLF & _
"- [x] (✅)测试" & @CRLF & _
"1. (✅)测试" & @CRLF & _
"2. [ ] (✅)测试" & @CRLF & _
"2. [x] (✅)测试" & @CRLF & _
"" & @CRLF & _
"测试" & @CRLF & _
"- 测试" & @CRLF & _
"- [ ] 测试" & @CRLF & _
"- [x] 测试" & @CRLF & _
"<mark style="background: #ffcc33aa;">demo</mark> 测试" & @CRLF & _
"" & @CRLF & _
"// 测试" & @CRLF & _
"%% 测试 %%"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")