$re = '/((?<!> )((\d{1,}\.|-|\/\/|\%\%|\#) )(\[[x ]\] )?)/m';
$str = '- 测试
- [ ] 测试
- [x] 测试
1. 测试
2. [ ] 测试
2. [x] 测试
- (✅)测试
- [ ] (✅)测试
- [x] (✅)测试
1. (✅)测试
2. [ ] (✅)测试
2. [x] (✅)测试
测试
- 测试
- [ ] 测试
- [x] 测试
<mark style="background: #ffcc33aa;">demo</mark> 测试
// 测试
%% 测试 %%';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);