using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?<!> )((\d{1,}\.|-|\/\/|\%\%|\#) )(\[[x ]\] )?)";
string input = @"- 测试
- [ ] 测试
- [x] 测试
1. 测试
2. [ ] 测试
2. [x] 测试
- (✅)测试
- [ ] (✅)测试
- [x] (✅)测试
1. (✅)测试
2. [ ] (✅)测试
2. [x] (✅)测试
测试
- 测试
- [ ] 测试
- [x] 测试
<mark style=""background: #ffcc33aa;"">demo</mark> 测试
// 测试
%% 测试 %%";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}