using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div\b.*?\bdata-id=\""([^""]*)\"">([^<]*).*?\/>([^<]*)<div\b.*?\bdata-id=\""([^""]*)\"">([^<]*).*";
string substitution = @"@['id':'$1','tag':'$2']; , $3@['id':'$4','tag':'$5'];";
string input = @"<div id=""tarea"" contentEditable=""true"" class=""tarea"" autocorrect=""false"" spellCheck=""off"">
Hello Says! <div class=""tag"" data-id=""1005"">Vedant Terkar</div> , <br />To all <div class=""tag"" data-id=""1006"">SO Users</div> :-).
</div>
<!-- This textarea is Usually Hidden -->
<textarea id=""opc"" rows=""5"" cols=""97"">
</textarea>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}