const regex = /<div\b.*?\bdata-id=\"([^"]*)\">([^<]*).*?\/>([^<]*)<div\b.*?\bdata-id=\"([^"]*)\">([^<]*).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<div\\b.*?\\bdata-id=\\"([^"]*)\\">([^<]*).*?\\\/>([^<]*)<div\\b.*?\\bdata-id=\\"([^"]*)\\">([^<]*).*', 'gm')
const str = `<div id="tarea" contentEditable="true" class="tarea" autocorrect="false" spellCheck="off">
Hello Says! <div class="tag" data-id="1005">Vedant Terkar</div> , <br />To all <div class="tag" data-id="1006">SO Users</div> :-).
</div>
<!-- This textarea is Usually Hidden -->
<textarea id="opc" rows="5" cols="97">
</textarea>`;
const subst = `@['id':'$1','tag':'$2']; , $3@['id':'$4','tag':'$5'];`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);