// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<div\b.*?\bdata-id=\"([^"]*)\">([^<]*).*?\/>([^<]*)<div\b.*?\bdata-id=\"([^"]*)\">([^<]*).*"#).unwrap();
let string = "<div id=\"tarea\" contentEditable=\"true\" class=\"tarea\" autocorrect=\"false\" spellCheck=\"off\">
Hello Says! <div class=\"tag\" data-id=\"1005\">Vedant Terkar</div> , <br />To all <div class=\"tag\" data-id=\"1006\">SO Users</div> :-).
</div>
<!-- This textarea is Usually Hidden -->
<textarea id=\"opc\" rows=\"5\" cols=\"97\">
</textarea>";
let substitution = "@['id':'$1','tag':'$2']; , $3@['id':'$4','tag':'$5'];";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}