# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\w)(\.\d)?/\1\2, /g;t' <<< "abcde
12345
1.523.545.5
"