$re = '/(\w)(\.\d)?/';
$str = 'abcde
12345
1.523.545.5
';
$subst = "\1\2, ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;