using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w)(\.\d)?";
string substitution = @"\1\2, ";
string input = @"abcde
12345
1.523.545.5
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}