using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*?([A-Z][a-z]+\W){3}).*$";
string input = @"This is my friend. He is very nice.
This is my friend John Michaels Fredrickson. He is very nice.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}