$re = '/^(?!.*?([A-Z][a-z]+\W){3}).*$/m';
$str = 'This is my friend. He is very nice.
This is my friend John Michaels Fredrickson. He is very nice.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);