re = /^(?!.*?([A-Z][a-z]+\W){3}).*$/m
str = 'This is my friend. He is very nice.
This is my friend John Michaels Fredrickson. He is very nice.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end