package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Z][\s\S]*?\.(?:\n\n|$)`)
var str = `This is a test! I would like to ensure the first character is a capital and the last is a punctuation with anything in between.
This is a test.
I would like to ensure the first character is a capital and the last is a punctuation with anything in between.
This is a test. I would like to ensure the first character is a capital and the last is a punctuation with anything in between.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}