const regex = /^[A-Z][\s\S]*?\.(?:\n\n|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Z][\\s\\S]*?\\.(?:\\n\\n|$)', 'gm')
const str = `This is a test! I would like to ensure the first character is a capital and the last is a punctuation with anything in between.
This is a test.
I would like to ensure the first character is a capital and the last is a punctuation with anything in between.
This is a test. I would like to ensure the first character is a capital and the last is a punctuation with anything in between.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}