// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[A-Z][\s\S]*?\.(?:\n\n|$)").unwrap();
let string = "This is a test! I would like to ensure the first character is a capital and the last is a punctuation with anything in between.
This is a test.
I would like to ensure the first character is a capital and the last is a punctuation with anything in between.
This is a test. I would like to ensure the first character is a capital and the last is a punctuation with anything in between.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}