$re = '/(\w+\s*)\1+/';
$str = 'This is is is is a test
Foo bar
Telelephone: +49 188/123 45 45 45';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);