re = /(\w+\s*)\1+/
str = 'This is is is is a test
Foo bar
Telelephone: +49 188/123 45 45 45'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end