import re
regex = re.compile(r"(\w+\s*)\1+")
test_str = ("This is is is is a test\n"
"Foo bar\n"
"Telelephone: +49 188/123 45 45 45")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")