import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\s*|\\r)+GO(\\s*);*\\s*(?:\\r|\\n)";
final String string = "GO;\n"
+ "[11-02-2016 08:14] Rene Krone: \n"
+ "/* To prevent any potential data loss issues, you should review this script in detail before running it outside the context of the database designer.*/\n"
+ "BEGIN TRANSACTION\n"
+ "SET QUOTED_IDENTIFIER ON\n"
+ "SET ARITHABORT ON\n"
+ "SET NUMERIC_ROUNDABORT OFF\n"
+ "SET CONCAT_NULL_YIELDS_NULL ON\n"
+ "SET ANSI_NULLS ON\n"
+ "SET ANSI_PADDING ON\n"
+ "SET ANSI_WARNINGS ON\n"
+ "COMMIT\n"
+ "BEGIN TRANSACTION\n"
+ "Go ;\n"
+ "ALTER TABLE dbo.ResultCodes ADD\n"
+ " ShortDescription nvarchar(50) NULL,\n"
+ " EnglishDescription nvarchar(100) NULL\n"
+ " gO;\n"
+ "ALTER TABLE dbo.ResultCodes SET (LOCK_ESCALATION = TABLE) GO PRINT 'PLEASE GO ; '\n"
+ "GO\n"
+ "COMMIT \n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}