# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\s*|\r)+GO(\s*);*\s*(?:\r|\n)"
test_str = ("GO;\n"
"[11-02-2016 08:14] Rene Krone: \n"
"/* To prevent any potential data loss issues, you should review this script in detail before running it outside the context of the database designer.*/\n"
"BEGIN TRANSACTION\n"
"SET QUOTED_IDENTIFIER ON\n"
"SET ARITHABORT ON\n"
"SET NUMERIC_ROUNDABORT OFF\n"
"SET CONCAT_NULL_YIELDS_NULL ON\n"
"SET ANSI_NULLS ON\n"
"SET ANSI_PADDING ON\n"
"SET ANSI_WARNINGS ON\n"
"COMMIT\n"
"BEGIN TRANSACTION\n"
"Go ;\n"
"ALTER TABLE dbo.ResultCodes ADD\n"
" ShortDescription nvarchar(50) NULL,\n"
" EnglishDescription nvarchar(100) NULL\n"
" gO;\n"
"ALTER TABLE dbo.ResultCodes SET (LOCK_ESCALATION = TABLE) GO PRINT 'PLEASE GO ; '\n"
"GO\n"
"COMMIT \n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.