import re
regex = re.compile((r"\n"
r".*((black\-?friday\.ga)|(alibestsale\.com)|(build\-?a\-?better\-?business\.2your\.site)|(callmebold\.com)|(centurylink\.net)|(cyber\-?monday\.ga)|(digg\.com)|(euro\.typepad\.jp)|(exmail\.qq\.com)).*\n"))
test_str = ("\n"
".*((black\\-?friday\\.ga)|(alibestsale\\.com)|(build\\-?a\\-?better\\-?business\\.2your\\.site)|(callmebold\\.com)|(centurylink\\.net)|(cyber\\-?monday\\.ga)|(digg\\.com)|(euro\\.typepad\\.jp)|(exmail\\.qq\\.com)).*\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")