re = /
.*((black\-?friday\.ga)|(alibestsale\.com)|(build\-?a\-?better\-?business\.2your\.site)|(callmebold\.com)|(centurylink\.net)|(cyber\-?monday\.ga)|(digg\.com)|(euro\.typepad\.jp)|(exmail\.qq\.com)).*
/
str = '
.*((black\\-?friday\\.ga)|(alibestsale\\.com)|(build\\-?a\\-?better\\-?business\\.2your\\.site)|(callmebold\\.com)|(centurylink\\.net)|(cyber\\-?monday\\.ga)|(digg\\.com)|(euro\\.typepad\\.jp)|(exmail\\.qq\\.com)).*
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end