// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"
.*((black\-?friday\.ga)|(alibestsale\.com)|(build\-?a\-?better\-?business\.2your\.site)|(callmebold\.com)|(centurylink\.net)|(cyber\-?monday\.ga)|(digg\.com)|(euro\.typepad\.jp)|(exmail\.qq\.com)).*
").unwrap();
let string = "
.*((black\\-?friday\\.ga)|(alibestsale\\.com)|(build\\-?a\\-?better\\-?business\\.2your\\.site)|(callmebold\\.com)|(centurylink\\.net)|(cyber\\-?monday\\.ga)|(digg\\.com)|(euro\\.typepad\\.jp)|(exmail\\.qq\\.com)).*
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}