package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\+?(6\d{2}|7[1-9]\d{1})\d{6}$`)
var str = `+795111111`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}