const regex = /^\+?(6\d{2}|7[1-9]\d{1})\d{6}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\+?(6\\d{2}|7[1-9]\\d{1})\\d{6}$', '')
const str = `+795111111`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}