import re
regex = re.compile(r"^\+?(6\d{2}|7[1-9]\d{1})\d{6}$")
test_str = "+795111111"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")