#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(https?):\/\/([0-9a-z.\-\/]+)"
Local $sString = "<div class="filefield-file"><img class="filefield-icon field-icon-application-vnd-ms-excel" alt="application/vnd.ms-excel icon" src="http://uristhome.ru/sites/all/modules/filefield/icons/x-office-spreadsheet.png"><a href="https://uristhome.ru/sites/default/files/doc/ks-6a.xls" type="application/vnd.ms-excel; length=51712" title="ks-6a.xls">Типовой бланк и форма КС-6а</a></div>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")