import re
regex = re.compile(r"(https?):\/\/([0-9a-z.\-\/]+)")
test_str = ("<div class=\"filefield-file\"><img class=\"filefield-icon field-icon-application-vnd-ms-excel\" alt=\"application/vnd.ms-excel icon\" src=\"http://uristhome.ru/sites/all/modules/filefield/icons/x-office-spreadsheet.png\"><a href=\"https://uristhome.ru/sites/default/files/doc/ks-6a.xls\" type=\"application/vnd.ms-excel; length=51712\" title=\"ks-6a.xls\">Типовой бланк и форма КС-6а</a></div>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")