const regex = /(https?):\/\/([0-9a-z.\-\/]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(https?):\\\/\\\/([0-9a-z.\\-\\\/]+)', 'g')
const str = `<div class="filefield-file"><img class="filefield-icon field-icon-application-vnd-ms-excel" alt="application/vnd.ms-excel icon" src="http://uristhome.ru/sites/all/modules/filefield/icons/x-office-spreadsheet.png"><a href="https://uristhome.ru/sites/default/files/doc/ks-6a.xls" type="application/vnd.ms-excel; length=51712" title="ks-6a.xls">Типовой бланк и форма КС-6а</a></div>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}