using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"'(?=[^""]*""(?:[^""]*""[^""]*"")*[^""]*$)";
string input = @"asdsd'asdsad""sdasd'asdasd"" asdsad'sadasdasd""aasd'asdasd""asdasd";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}