import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "'(?=[^\"]*\"(?:[^\"]*\"[^\"]*\")*[^\"]*$)";
final String string = "asdsd'asdsad\"sdasd'asdasd\" asdsad'sadasdasd\"aasd'asdasd\"asdasd";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}