$re = '/\'(?=[^"]*"(?:[^"]*"[^"]*")*[^"]*$)/i';
$str = 'asdsd\'asdsad"sdasd\'asdasd" asdsad\'sadasdasd"aasd\'asdasd"asdasd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);