use strict;
my $str = '21, 2, \'23.5R25 ETADT\', \'description, with a comma\'
22, 1, \'26.5R25 ETADT\', \'Description without a comma\'
23, 5, \'20.5R20.5\', \'Another description with ; semicolumn\'';
my $regex = qr/,?[ ]*([^',\n]*(?:'[^'\n]*'[^',\n]*)*)/mp;
my $subst = '\\1\\t';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";