import Foundation
let pattern = #",?[ ]*([^',\n]*(?:'[^'\n]*'[^',\n]*)*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
21, 2, '23.5R25 ETADT', 'description, with a comma'
22, 1, '26.5R25 ETADT', 'Description without a comma'
23, 5, '20.5R20.5', 'Another description with ; semicolumn'
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\t"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)