using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*3.5.*";
string input = @"12345
12395
12335
123445
123945
123495
123995";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}