$re = '/.*3.5.*/';
$str = '12345
12395
12335
123445
123945
123495
123995';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);