import re
regex = re.compile(r".*3.5.*")
test_str = ("12345\n"
"12395\n"
"12335\n"
"123445\n"
"123945\n"
"123495\n"
"123995")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")