import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=https?:\\/\\/[^ ]+-booker[^ ]+)(.*)";
final String string = "http://domain.local/htmlforms/mforms/product1-booker.html\n"
+ "http://domain.local/htmlforms/mforms/product2-booker.html\n"
+ "http://domain.local/htmlforms/mforms/product3.html\n"
+ "http://domain.local/htmlforms/mforms/product4.html\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}