$re = '/(?=https?:\/\/[^ ]+-booker[^ ]+)(.*)/';
$str = 'http://domain.local/htmlforms/mforms/product1-booker.html
http://domain.local/htmlforms/mforms/product2-booker.html
http://domain.local/htmlforms/mforms/product3.html
http://domain.local/htmlforms/mforms/product4.html
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);