const regex = /(?=https?:\/\/[^ ]+-booker[^ ]+)(.*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=https?:\\\/\\\/[^ ]+-booker[^ ]+)(.*)', 'g')
const str = `http://domain.local/htmlforms/mforms/product1-booker.html
http://domain.local/htmlforms/mforms/product2-booker.html
http://domain.local/htmlforms/mforms/product3.html
http://domain.local/htmlforms/mforms/product4.html
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}