package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\(((?:'[^']*'|[^()])*)\)`)
var str = `(45171924,-1,'AbuseFilter/658',2600),(43795362,-1,'!!_(disambiguation)',2600),(45795362,-1,'!!_(disambiguation)',2699)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}