re = /\(((?:'[^']*'|[^()])*)\)/m
str = '(45171924,-1,\'AbuseFilter/658\',2600),(43795362,-1,\'!!_(disambiguation)\',2600),(45795362,-1,\'!!_(disambiguation)\',2699)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end