$re = '/\(((?:\'[^\']*\'|[^()])*)\)/m';
$str = '(45171924,-1,\'AbuseFilter/658\',2600),(43795362,-1,\'!!_(disambiguation)\',2600),(45795362,-1,\'!!_(disambiguation)\',2699)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);