#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:\S)(https?:[\S]*)(?:&ct=ga&cd=)"
Local $sString = "https://www.google.com/url?rct=j&sa=t&url=http://4pda.ru/forum/index.php?showtopic=701750&st=7440&ct=ga&cd=CAEYACoUMTQzMjUxOTE3ODExNDA5NDA0ODcyHGU3M2YyMjY3MmQ0NTY5MzU6cnU6ZW46UlU6Ukw&usg=AFQjCNGp1zcChJ_QT82U_lt_rWOuIkasBg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")